Cisco路由器广域网配置向导 - fanqiang.com

来源:百度文库 编辑:16楼社区 时间:2020/10/31 03:29:51

Cisco路由器广域网配置向导

来源:不详 (2001-05-02 00:52:54)
概述

Cisco IOS提供了广阔范围的广域网网络性能,适合于各种网络环境需要.Cisco提供了信元
转播SMDS( Switching Mutilmegabit Data Service),电路交换ISDN( Integrated Services 
Digital Network),包交换Frame Relay以及兼容电路交换和包交换好处的ATM( Asynchronous 
Transfer Mode.局域网仿真( LAN emulation)提供了ATM和各种局域网类型的连接.

Cisco的拨号备份提供了当广域网出现故障时的连接访问.DDR(Dial-on-Demand routing)提供
了灵活的用Modem或ISDN连接上广域网.拨号连接可以使用链路访问程序,LAPB,PPP,X.25和帧
中继实现.
  • 概述
  • 配置DDR
  • 配置帧中继
  • 配置DDN
  • 配置X.25
  • 广域网配置实例

概述

Cisco IOS提供了广阔范围的广域网网络性能,适合于各种网络环境需要.Cisco提供了信元转播SMDS( Switching Mutilmegabit Data Service),电路交换ISDN( Integrated Services Digital Network),包交换Frame Relay以及兼容电路交换和包交换好处的ATM( Asynchronous Transfer Mode.局域网仿真( LAN emulation)提供了ATM和各种局域网类型的连接.

Cisco的拨号备份提供了当广域网出现故障时的连接访问.DDR(Dial-on-Demand routing)提供了灵活的用Modem或ISDN连接上广域网.拨号连接可以使用链路访问程序,LAPB,PPP,X.25和帧中继实现.

 


配置DDR

Dial-on-demand routing(DDR)是用公共电话网提供了网络连接.通常的,广域网大多数用专线连接的,路由器连接到类似modem或ISDN TAs的数据终端DCE设备上,它们支持同步V.25bis协议,你可以用scripts和dialer命令设定拨号串.

DDR比较适用于用户对数率要求不高,偶尔有数据传输或只是在特定时候传输数据,比如银行每晚传送报表等等情况下.

当一个感兴趣的包到达路由器时,产生一个DDR请求.路由器发送呼叫建立信息给指定的串口的DCE设备.这个呼叫就把本地和远程的设备连接起来.一旦没有数据传输,空闲时间开始计时,超过设置的空闲时间,这一次连接终止.DDR现在都用静态路由来传输数据包,避免路由交换引起的DDR拨号.

AppleTalk,Banyan VINES, CLNS, DECnet, IP, IPX, 和XNS可以通过DDR路由寻址.同步串口,异步串口和ISDN端口可以配置成到一个或多个目的地DDR连接.

下图是一个典型的DDR连接:

在配置DDR过程中,我们可以把一个或几个物理接口配置成一个逻辑拨号接口,它可以是同步V.25方式,同步DTR启动拨号或异步chat script方式.

在端口配置模式下:

功 能 命 令 在一个端口上激活 Dial-on-demand routing dialer in-band 指定一个端口为拨号访问组 dialer-group group-number 指定一个单一电话号码 dialer string dial-string 断线前空闲等待时间 dialer idle-time seconds 定义一个或多个目的电话号码表 dialer map protocol net-hop-address dialer-string 限定传输的access-list表或特定协议 dialer-list dialer-group list access-list-number

dialer-list dialer-group protocol protocol-name {permit|deny|list access-list-number}

其中dialer string和dialer map两条命令任选一,dialer string是在只有一个电话号码时用,而dialer map是一个电话号码表.

详细配置说明请参阅下面"DDR Example"的实例.

配置拨号备份

拨号备份提供了一种保护,使得当广域网上主干线出现故障时,启动一条备份线路,使通信正常运转.

启动备份有两种情况:

主干线断掉

传输流量超过了定义的最大值

需作的定义如下:

在主干线路端口上设置它的备份端口 backup interface interface-name 定义备份负载 backup load {enable-threshold | never} {disable-load |never} 定义主干线up或down的响应时间 backup delay {enable-delay | never) {disable-delay | never}

其中: enable-threshold --- 表示主干线超过总传输量的百分比,启动备份线路

disable-load --- 表示传输量减少百分之多少就断开备份线路.

enable-delay --- 表示主干线断开多长时间后,启动备份线路.

disable-delay --- 表示主干线又重新恢复多长时间后,断开备份线路.

详细配置说明请参阅下面"Dial Backup Example"的实例.

 


配置帧中继

帧中继是一种由ANSI和CCITT标准化的协议,它能为现今突发性业务流量(如LAN互连及SNA业务)提供显著的性能价格优势.帧中继是客户端设备(CPE),诸如路由器或前端处理器,和一个向远程CPE发送数据的广域网之间的一种接口协议.它有以下几个特点:

  • 低时延
    时延是指一个给定待发送帧穿过网络到达远程用户设备所用的时间.当网络时延增大时,性能会下降;尤其对于敏感协议(如SNA和DECnet),所有帧被发送后必须等待应答的协议(即Novell IPX),以及利用短交易式的应用.
  • 可靠性
    在给定时延条件下,吞吐量随着网络的可靠性变化而变化,可靠性好,超时等待重发帧越少,吞吐量就会大大增加.
  • 更低的联网开销
  • 可预测性
    在许多网络环境中,如SNA CICS,不仅要求时延低,而且需要可预测性.
  • 公平性

Cisco's Frame Relay目前支持IP,DECnet,AppleTalk, Xerox Network Service (XNS), Novell IPX, International Organization for Standards (ISO) Connectionless Network Service (CLNS), Banyan VINES, 和 transparent bridging在帧中继中传输.

典型的帧中继连接图:

配置帧中继的工作表:

  • 在一个端口上作帧中继打包
  • 定义动态或静态的地址映射
  • 定义LMI
  • 配置帧中继交换虚电路
  • 帧中继交换
  • 监控帧中继连接

在一个端口上作帧中继打包

某一端口上配置帧中继打包走帧中继协议,在global配置模式下:

功 能 命 令 指定走帧中继的端口并进入端口配置模式 interface serial number 指定帧中继打包方式 encapsulation frame-relay [ietf]

Cisco的帧中继与RFC 1490的打包方式一致,允许不同厂家的产品互相通信.当与其它厂家路由器连接时,请用IETF打包.

定义动态或静态的地址映射

动态地址映射

动态地址映射用帧中继的翻转ARP协议发送请求下一个希望到达的地址(next hop protocol address)(假设知道DLCI),当有应答翻转ARP协议请求时,保存在address-to-DLCI映射表中,这张表就用来提供下一个希望到达的地址或出去的DLCI地址.

翻转ARP协议默认是打开的,故动态地址映射不需要做任何配置.

静态地址映射

一个静态地址映射是人为的指定下一个希望到达的地址(next hop protocol address)与DLCI的对应关系.当指定了静态地址映射时,翻转ARP协议自动关闭.

建立静态地址映射表需完成:

功 能 命 令 定义一个端口或子端口的DLCI地址 frame-relay interface-dlci dlci 指定一个next hop protocol address与DLCI之间对应 frame-relay map protocol protocol-address dlci [broadcast] [ietf] [cisco]

相应地,关键字protocol支持的协议:

  • IP---ip
  • DECnet---decnet
  • AppleTalk---appletalk
  • XNS---xns
  • Novell IPX---ipx
  • VINES---vines
  • ISO CLNS---clns

如果是一点对一点,可用interface-dlci命令,若是一点对多点则设定 frame-relay map 一系列的dlciip address 对应表.

定义LMII

在Cisco IOS Release 11.2版本以上,支持本地管理接口LMI(Local management Interface)自动识别,即由交换机端口决定LMI的类型.当然,我们也可以明确配置LMI类型.

功 能 命 令 建立路由器间keepalive时间 frame-relay keepalive number 定义N391的间隔时间 frame-relay lmi-n391-dte keep-exchanges

 

配置帧中继交换虚电路

目前,访问帧中继网是56K到45M数率,帧中继是在两个节点间建立面向连接的,包交换的虚电路.

  • 在一个物理端口上配置SVCs
  • 在子端口上配置SVCs

在一个帧中继端口上配置SVC操作

功 能 命 令 指定物理端口 interface serial number 如果需要,配置IP地址 ip address ip-address mask 在这个端口上配置帧中继打包 encapsulation frame-relay 在这个端口上激活帧中继SVC frame-relay svc

在子端口上配置SVCs

功 能 命 令 在主端口上指定一个子端口 interface serial number.subinterface-number {multipoint | point-to-point} 如果需要,配置IP地址 ip address ip-address mask

参阅下面"Configure subinterface Example"的例子.

帧中继交换

当一个帧中继网要通过IP网与另一个帧中继网互连,就要用到帧中继交换.把IP网看作帧中继包的隧道通过去.

实现帧中继交换,配置如下:

功 能 命 令 把路由器作为帧中继交换机 frame-relay switching 在路由器上设置静态路由 frame-relay route in-dlci out-interface out-dlci 定义网络功能 frame-relay intf-type {dte| dce| nni}

请参阅"Frame Relay Switching Example"配置实例.

监控帧中继连接

在EXEC模式下:

功 能 命 令 显示帧中继DLCI和LMI信息 show interface serial number 显示LMI状态 show frame-relay lmi [type number] 显示PVC状态 show frame-relay pvc [type number [dlci]] 显示配置静态路由 show frame-relay route 显示帧中继传输状态 show frame-relay traffic

 


配置DDN

DDN(Digital Data Network)是一种点对点的同步数据通信链路.它支持PPP,SLIP,HDLC和SDLC等链路层通信协议.允许IP, Novell IPX, Bridging,CLNS,AppleTalk,DECnet等多种上层协议在上面运行.

  • 基本配置
  • 压缩技术
  • E1端口配置

基本配置

功 能 命 令 进入指定端口 interface serial number 定义该端口IP地址 ip address ip-address mask 指定该端口打包方式 encapsulation {PPP| HDLC }

压缩技术

通常在串口中传输的数据是不压缩的,它允许数据包头在每次传输时正常交换,但每次将浪费带宽.目前支持的压缩有PPP,Frame Relay, X.25, TCP等等.

Cisco的压缩是通过软件完成的,将影响系统性能.故建议路由器CPU占用超过65%,就不要使用压缩.(show process cpu EXEC命令查看当前CPU使用情况)

功 能 命 令 TCP传输头压缩 ip tcp head-compression [passive] X.25压缩 X25 compress PPP压缩 ppp compress [predictir|stac]

注: "passive"表示只有输入包是压缩时,输出包才压缩.

E1端口配置

在Cisco 4500,4700,7000和7500系列里面均支持E1(2.048Mbps)数率的接口.每一个E1端口可以按时隙分成30路64K数据线路和2路信号线路.这30个64K数据线路每一路均可以当作一条64K的专线.

功 能 命 令 在配置模式下,定义Controller E1 controller e1 slot/port 定义line code linecode {ami |hdb3} 定义字符帧 framing {crc4 |no-crc4} 定义E1组 channel-group number timeslots range [speed {48| 56| 64}] 指定串口属于那一个channel-group组 interface serial slot/port:channel-group

注:

slot/port----是针对7000或7500系列的,故区分槽口号和端口号.

linecode----默认是HDB3.

framing----默认是crc4,要与电信局参数匹配.

channel-group----每个E1可以分成30个channel-group,把channel-group和时间槽对应起来.channel-group是0-30,timeslots是1-31.

interface serial----在定义完E1 channel-group后,我们把group赋予成一个虚拟串口.

具体的请参阅"Channelized E1 Interface Example"实例.

 


配置X.25

X.25配置完成如下工作:

功 能 命 令 设置X.25模式 encapsulation x25 [dte|dce] 设置最大虚电路数 x25 htc max-vc-number 设置X.121地址 x25 address x121-address 建立IP地址与X.121地址对应 x25 map ip ip-address x121-addres [broadcast]

htc----htc是最大的虚电路数,因为许多X.25交换机是从高到低建立虚电路的,max-vc-number不能超过申请的最大值.

请参阅"X.25 Example"的配置实例.

 


广域网配置实例

  • DDR Example
  • Dial Backup Example
  • Configure subinterface Example
  • Frame Relay Switching Example
  • Channelized E1 Interface Example
  • X.25 Example

DDR Example

Configuration for RouterA:

ip route 131.108.29.0 131.108.126.2
ip route 131.108.1.0 131.108.126.2
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx deny
!
interface serial 0
ip address 131.108.126.1 255.255.255.0
dialer in-band
dialer-group 1
!
dialer map ip 131.108.126.2 5551234
!
dialer idle-timeout 300

Dial Backup Example

A)同步V.25 bits方式

Configuration for RouterA:

interface Serial0:0
backup delay 0 10
backup interface Serial10
ip address 16.217.30.2 255.255.255.252
!
interface Serial10
ip address 16.30.16.81 255.255.255.0
encapsulation ppp
dialer in-band
dialer string 8292
dialer-group 1
pulse-time 1
!
dialer-list 1 protocol ip permit

B)辅助口作拨号备份

Configuration for RouterA:

chat-script MYDIAL "" "atdt 8292" TIMEOUT 60 "CONNECT"
!
interface Serial0
backup delay 0 0
backup interface Async1
ip address 16.3.1.1 255.255.255.0
encapsulation ppp
!
interface Async1
ip address 16.3.2.1 255.255.255.0
encapsulation ppp
keepalive 9
async default routing
async dynamic address
async dynamic routing
async mode dedicated
dialer in-band
dialer string 8292
dialer-group 1
!
dialer-list 1 protocol ip permit
!
line aux 0
script dialer MYDIAL
modem InOut
transport output none
stopbits 1
flowcontrol hardware
speed 9600

Subinterface Example(Frame Relay)

Configuration for RouterA:

interface serial 0
encapsulation frame-relay
interface s 0.1 multipoint
ip address 11.10.11.1 255.255.255.0
frame-relay interface-dlci 41
frame-relay interface-dlci 42

Configuration for RouterC:

interface serial 0
encapsulation frame-relay
interface s 0.1 point-to-point
ip address 11.10.16.2 255.255.255.0
frame-relay interface-dlci 46

Configuration for RouterB:

interface serial 0
encapsulation frame-relay
interface s 0.1 multipoint
ip address 11.10.11.3 255.255.255.0
frame-relay interface-dlci 43
frame-relay interface-dlci 44
!
interface s 0.2 point-to-point
ip address 11.10.13.1 255.255.255.0
frame-relay interface-dlci 48

Frame Relay Switching Example

Configuration for RouterA:

frame-relay switching
!
int s 0
no ip address
frame-relay encapsulation
frame-relay route 167 tun0 43
frame-relay intf-type dce
!
int s 1
ip address 131.108.100.1 255.255.255.0
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.13.2

Configuration for RouterB:

frame-relay switching
!
int s 0
no ip address
frame-relay encapsulation
frame-relay route 9 tun0 43
frame-relay intf-type dce
!
int s 1
ip address 131.108.13.2 255.255.255.0
!
int tu 0
tunnel source serial 1
tunnel destination 131.108.100.1

Channelized E1 Interface Example

假设是7500系列路由器,E1接口(MIP板)在插槽4上面.

一个channel-group可对应多个时间槽,本例中serial4/0:1有5*64Kbps的数率.

Configuration for Router:

controller E1 0
framing NO-CRC4
channel-group 0 timeslots 1
channel-group 1 timeslots 2,7-9,20 speed 64
!
interface Serial4/0:0
ip address 16.217.30.2 255.255.255.252
encapsulation ppp
!
interface Serial4/0:1
ip address 16.205.30.5 255.255.255.252

X.25 Example

在配置X.25时,为减少路由交换引起的呼叫,通常用静态路由.而当一对多情况下,不在一个子网中用subinterface配置.

Configuration for Router:

interface serial 0
ip address 131.108.100.1 255.255.255.0
encapsulation x25
x25 address 041673226839
x25 htc 16
x25 map ip 131.108.100.2 041675222222
int s 0.1
ip address 131.108.101.1 255.255.255.0
x25 map ip 131.108.101.2 041674222222
!
ip route 131.108.100.0 255.255.255.0 131.108.100.2
ip route 131.108.101.0 255.255.255.0 131.108.101.2






(http://www.fanqiang.com)